Can't run 1.3 alpha 0.14 on Windows

I just downloaded this alpha version to try it, but it gives me error message look like:

105

I tried to clean up all exist pk3 files, sadly still persist.

1 Like

Howdy Billy :slight_smile: ! Please post a list of the contents of the folder where you have the Tremulous 1.3 client binary.

1 Like

1 Like

Could you also show the contents of the gpp folder inside the Tremulous 1.3 Alpha 0.14 folder? Do you run tremulous.exe from its location in that first screenshot, do you use a shortcut to it?

Sorry for late posting, done for working few days earlier.

Yes.

I already did, but still same issue.

Maybe try moving that 1.3 folder to your Documents folder, maybe it is having issues running from your D drive?

Tried moving to Documents folder, still not working.

Not sure how my PC unable to start alpha 0.14 properly, but still working on alpha 0.8.

Very Weird…

Howdy @BillyRazOr2015 :), it appears you don’t have an autogen.cfg. I would advise doing a full uninstall of Tremulous and the 1.3 client, (deleting all folders left over) and re-installing Tremulous and then replacing that with the respective 1.3 client. Normally Tremulous should generate an autogen if launched no? If possible, could you also please attach the clipboard of the crash log when the error occurs.

You could also attempt to clean things up in %AppData%, like the halloween_unitremia_18 folder, test7341 or unitremia_0014.

Here is an example of my %appdata% roaming folder:
image

1 Like

error log.txt (19.8 KB)
error log 2.txt (22.6 KB)

1 Like

Hmm, from the looks I found this:

----- Client Shutdown (Client fatal crashed: Couldn't open G:\Tremulous\base\data-1.1.0.pk3) -----

Can you find that exact location? Perhaps your 1.1.0.pk3 is corrupted or not existent, thus prompting a re-installation or getting a copy of a good version of the .pk3. Check if you have the data-1.1.0.pk3 in base.

I’ll try it and see if any changes. :+1:

2 Likes

Tried to new copy by re-download and copy for exact same file, still have issues. :frowning:

1 Like

Hmm, I’m afraid I am out of ideas as of the current moment™.

I dont know what the correct filepaths are for 1.3 client , but im going to assume that it is similar to 1.1. “cannot load default.cfg” I found is caused when you have a file (usually the data.pk3) in the wrong spot. No other pk3s should be in the base folder except for default data and vm pk3s (such as data-.1.1 and data-gpp.pk3) and maps. Try moving the alpha pk3s that you want to try to their own folder outside the base folder (such as your other mods are), and make sure the folder has the proper name.
correct name is probably “trem_1-3_alpha014” but im not sure. Good Luck

2 Likes

@BillyRazOr2015 I think your issue is with an incorrect cvar option read from your autogen.cfg - for both fs_basepath - which should be D:\Tremulous 1.3 Alpha 0.14\ in your case but looks like it was trying to use your G:\ drive, and also fs_homepath is set incorrectely as well - is it supposed to be using C:\Users\Asus\ or C:\Users\BillyRazor\ ?

Try temporarily renaming autogen.cfg in your %appdata%/gpp/ folder (or edit it, looking for wrongly set fs_ cvar values) and try running trem again. Additionally, you can specify +set fs_homepath "C:\appdatastuff" +set fs_basepath "D:\Treminstallplace" as arguments at runtime using the windows shortcut you made for tremulous.exe

3 Likes

Tried to edit, but nothing works.

I tried it, it did running. But after 2 seconds, this time the error message were different.

recursive error.txt (18.8 KB)

1 Like

@BillyRazOr2015 Do all of the following:

  1. Move ALL of your map *.pk3 files out of the incorrect C:\Users\Asus user to your current windows user C:\Users\BillyRazor\Roaming\Tremulous\base folder. Delete the Trem folders for the Asus user.

  2. Backup and then delete your old autogen.cfg here (in %appdata%/Tremulous/) too

  3. Move or delete D:\Tremulous\ nonsense out of the way

  4. Move or delete G:\Tremulous\ nonsense out of the way

  5. Check for the existence of any other incorrect file locations like C:\Program Files (x86)\Tremulous

  6. Check your shortcut to Trem, ensuring its “Target” and “Start in” locations both use D:\Tremulous 1.3 Alpha 0.14\

Try to get all of the old cruft out of the way and see if it works.

3 Likes
© GrangerHub. All rights reserved. Tremulous © Darklegion Development. Granger by err-overflow and MoP licensed CC-BY-SA-2.5