G_Unlagged is borked for everyone it seems


#1

Probably needs a hard reset. Either that or someone must’ve fucked with the settings by setting sv_fps to something dorky like 100.

Confirmed g_unlagged = 1
and cG_unlagged = 1 (untouched, at the beginning of he footage I’m on DerBunker and it works there albeit it isn’t precise and a little inconsistant as my ping passes the 350msec mark)
and that my ping is under 400 msec* during most of these sessions.

*The hard limit should actually be around 500msec as the game has 10 slots of memory, DevHC fixed that bug back in the acidtu.be Cuboid days…


#2

Thank you for bringing this to our attention @ViruS :slight_smile:

We had sv_fps set to 40 on GrangerPub, I lowered it now to 20 for now since MAX_UNLAGGED_MARKERS is set to 10 on multiprotocol slackers (which is the repo that GrangerPub is currently using) as you mentioned (which means with a server frame rate of 40, unlagged would only go back 250 milliseconds).

I notice that in the 1.3 code MAX_UNLAGGED_MARKERS is set to 256 which would be sufficient for over 500 server frames per second to go back 500 milliseconds (although there is a lot of other things that need adjustment before we can reach that server frame rate, lol), so the 40 fps we have set on the GrangerLab server and on the Unitremia server should not be an issue for unlagged, just make sure you set /snaps to 40.


#3

The guy with 130 ping said he had to lead his shots as well so I don’t think this is the case.

Also I don’t think it is as simple as setting MAX_UNLAGGED_MARKERS


#4

@ViruS , when you get a chancem let me know if the Unlagged feels better on GrangerPub.

I have noticed that on GrangerLab and Untremia, when the server frame rate is set to 40, and a client has its snaps set to 20 (which is currently a common default setting on clients), they do have higher ping than if they have snaps set to 40, and your ping reduces if you increase your snaps to match the server frame rate.


#5

having 20 as opposed to 40 makes very little difference.
Tremulous defaults to 40 without an autogen.cfg though afaik so I don’t think that should be the case.