Regular error when compiling mods. (Fatal error in q3lcc)


#1

When I am compiling a wide range of tremulous mods, I get this error message very often and have tried a lot of things and haven’t seemed to find a solution anywhere. Here is the updated error : https://pastebin.com/VLjeEqni


#2

Hmm, what were the dozen lines or so of output above that?


#3

https://pastebin.com/VLjeEqni


#4

It is possible that the issue might be with the repo’s support for building on 64 bit systems. I haven’t worked much on makefiles, but I recommend taking a look at 1.3’s makefile to see how it handles building on 64 bit systems, and see if you can use that for inspiration on how to fix up the makefile for the Z mod on 64 bit systems: https://github.com/GrangerHub/tremulous/blob/master/Makefile .


#5

I just tried compiling it on a 32 bit system and I get the same error.


#6

From what I recall when I compiled on Windows 7 x64 (On both mingw32 and mingw64.)
It was something to do with dependencies or the paths. (Might not be that, but it could be.)

Make sure that your PATHS are set correctly. (You might have to check the makefile to see if it uses any PATH from dependencies. Usually it should not be the case, but I had that problem in the past where I had to change the lcc’s in the makefile to specify where it was after Jkent shared me a precompiled one before I managed to compile it.)

Anyway, try making sure all the dependencies needed are there. (Could also be the version of the dependencies used not working since some things might be removed in further version of those dependencies.)

Sorry if I couldn’t help more, but that was the problem I had.