[SOLVED] Alpha version 0.9-0.13 crashed


#1

I tried to run from a0.9 to a0.13 and it’s giving this error message:

78

I don’t know what kind of this messy stuff… Since I updated a0.7 and a0.8 were worked for me, other versions are kindly unsupported my PC. (currently I’m using Windows 8.1)

Hope everyone will find this bug. :slight_smile:


#2

Hi @BillyRazOr2015 :slight_smile: , when does that crash occur? Does it happen as soon as you run the client so that you don’t even get to the main menu, or can you get to the main menu, in which case does the crash happen when you try to connect to a server? Which operating system are you using (if Windows, which version of Windows)?


#3

Almost a year ago until now

I just open “tremulous.exe” to run it, and then it crashed like this error on screenshot. So yeah, I can’t run it to main menu.

Windows 8.1 (Windows 7 and 10 are haven’t try it yet, but I can’t wasting my rest time to investigate about it)


#4

Which map pk3 contains traffic-lights.shader?


#5

That’s my own created shader files for testing.


#6

And what happens if you remove/move the pk3 containing that shader?


#7

Same, but other path show as error message:

79


#8

Ok now we’re getting somewhere… The file data-1.1.0.pk3 (as well as data-gpp1.pk3, data-v1.3.0-alpha.0.13, and default maps map-*.pk3) should be in D:\Tremulous\gpp\ (not base). Move or rename your %appdata%/Tremulous folder, to make it’s not loading any incorrect .cfgs - OR, run trem with a shortcut to specify: +set fs_basegame "gpp"

The alpha client does NOT need any prior version of trem installed, nor should it be extracted on top of any existing trem install… so if you had a 1.1 or gpp client in D:\Tremulous from before, rename that folder, and re-extract the alpha client’s zip into it’s own, empty, folder.


#9

I made as your follow, still not working. :confused:


#10

Send a screenshot of the folder where you have trem installed


#11

Did you try running the game in administrator?
Sometimes Windows blocks reading/writting requests from unknown programs/softwares.

If this does not work, I would suggest making a backup of your qKey (GUID) (It should be in %APPDATA%/tremulous/) So you do not lose any access or privilege that may have been given to you in the past such as being admin on the different servers you play and so on. (Just to make sure that a fresh tremulous install will not override the current existing qKey. It happened to me in the past.)
Now do as Cron(@romdos) said.
(You can do a backup of your installation folder first, incase it is correctly setup or you had binds and such that you might want to keep.)
Once your installation folder backup is done, (optional, but recommended.)
Delete your tremulous installation folder completely.
Download the 1.3 zip file. (You might want to start the download before doing anything else, this way it is ready when you are ready to install/unzip it.)
Unzip the zip file content where you want the installation to be. (For example: D:/Tremulous/1-3/)
Then try running the client in administrator so the functions/methods that might write/read from the disk drive has the correct privilege. (You should not need to run the game in administrator every time as once the files are written on the disk they can be read without any problem. (Generally.))
Then if you connect to a server, make sure your administration rights are still correct. If they are not, you can copy your qKey backup back into your %APPDATA%/tremulous folder.
If that does not work, please do post a screenshot down below showing your installation folder.

Hopefully this helped.


#12

Here:


#13

@BillyRazOr2015 you need to extract the alpha client into an empty NEW folder - you have way too much junk in your install!

You totally ignored what I said:

See how I do not have any extra stuff like you have? No base folder, no gpp-bot, etc…

clean


#14

Dang! What a messy… xD

I’ll try extract to another folder with clean state. Thanks @romdos! :smiley:


#15

I made on another folder and it works for me! :smiley: And it still have my original name as with qkey.

Screenshot from Alpha 0.13:

Thanks @romdos for your solution! :smile: :+1:
Problem solved!


#16

Oh! I forgot something! Does my stored/downloaded mapping still playable at my old path folder as well?


#17

It still uses the same tremulous homepath folder (you can find that by entering /fs_homepath). The homepath is where your qkeys, maps, mod downloads, screenshots, and demos would be located (which is why your name is still the same). To test maps, place maps in the base folder inside your homepath folder.

While the folder that you unzipped the 1.3 installation to is set as the basepath folder, which contains the default assets and executables, and that basepath folder should be kept clean, so you should not put any additional files inside that basepath folder.


#18

Ok!

I just found out why it doesn’t load Alpha version properly and crash. :open_mouth:

83

This 2 mappings, were caused conflict and crashed on this error. Currently I still don’t know how these 2 mappings are causing Alpha version to collide.

84

Other mappings will possible crash it again. Hope everyone understand. :slight_smile:


#19

Could they be using resources no longer available?
But yea, Great to know that some maps compatibility is being broken :stuck_out_tongue:


#20

Maybe. Some map engine are being too far from released mapping earlier GPP version or before 1.1 compatible, my own mapping doesn’t have any problems for 1.3. So I still didn’t find bugs for any commands that goes wrongly. :stuck_out_tongue:

I just cleaned up my messy Tremulous and re-installed again, almost nothing problem. Only small piece of bug on Alpha version as I told it about these 2 mappings.